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Artisan 1.3 Release Notes 

By Marko Luther, Dave Baxter, Rui Paulo and Michael Herbert 
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Watch out! You must start monitoring the roaster before pre-

heating.  Never leave the roaster alone, as you are fully 

responsible for controlling Artisan and the roaster. 

 

Install Notes 

On a PC, the installer will first remove your prior version but this won’t remove your prior settings if you 

have them.  On a MAC, your settings will be saved as well.  You can also downgrade to a previous 

version by just uninstalling the current version and re-installing the old version without losing any 

settings.  On a MAC, you will get a warning that Artisan is from an unidentified developer.  That is being 

worked on but go to Settings>Security and Privacy, and you will be able to allow Artisan to install.  NOTE, 

we still advise you to save stable settings before changing any settings or installing a new version 

(Help>Save Settings). 

Further information here: 

https://github.com/artisan-roaster-scope/artisan/blob/master/wiki/Installation.md 

Highlights 
 
Simplified dialogs and reordered menus 
Tools>Extras has been moved to “Config>Curves”  You will also find a new menu item View – which 

controls what you view on your screen - Controls, Readings, Buttons, Sliders, LCDs, Full Screen.  Some 

items have been moved, like "Temperature", which allows to set the display temperature unit to F or C. 

This one moved from Roast to Config, where it fits better. 

New “Configuration” menu:  Curves is moved from Tools>Extras.  And the dialog for Curves is simplified 

with most users only needing to be concerned with the first two tabs.  Although we recommend going 

to the UI tab and checking decimal places.  This will be turned on by default in a  future version. 

https://github.com/artisan-roaster-scope/artisan/blob/master/wiki/Installation.md
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Under the new View menu, you determine what you see in the program at any given time including 

basic Controls, Readings (BT, ET, etc LCD’s on the right), Buttons and Sliders.   

 

 

Fantastic New Custom Event Rendering Options 
You now have the option to render event descriptions instead of values.  In addition, 1.3 adds a new 

custom event button type "--" that adds an event (compared to the pure action button of type " ") and 

can be used to add labels to the graph rendering its button description.  For those using sliders the 

rendering will continue to be the first letter of the Event name and two digits of the value IF you check 

Decimal Places under Config>Curves>UI.  If you don’t it will render only one digit.   

Under Config>Events on the right side of the dialog box you will see under Events you now have a drop 

down with these options: 
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Flag will you an event either on your ET line or your BT line (check the box “show on BT”) and your event 

description if you check the box for Descr.  (number represents how many letters) or it will show the 

first letter of your event name and the event value if you do not.   

Bar will show you a multicolored bar at the bottom of your graph with the first letter of your event 

name and the event value.  Description is not relevant.   

Step will show you a plot (step) graph with no values.   

Step + shows you a plot graph plus your descriptors on the BT line (same choices as under Flag) 

Combo shows you a plot graph with the descriptors on the plot (step) graph.    

Here are examples: 

Combo 
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Step +

 

 

You are also now able to add an event type that will show on the graph when you hit the event button.   

With this new button type, you can define a button that will add an event item labeled with the 

description that shows up on the graph at the moment in time you press the button.  You could record 

when you take a sample from the trier as an example.   

 

New LCD Readout features 
1.3 adds expected time to DRY and FCs to phases LCDs in percentage and temperature mode. 

New Area Under Curve Features 
You can now see your Area Under Curve.  AUC will be recomputed for ranking reports based on actual 

AUC settings under Config>Statistics.  This will make AUC very useful in ranking reports.  Generally AUC 

is useful tool to compare roasts of the same bean. 
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Curves Dialog Box Simplification 
These are critical settings within Artisan and for most the first two tabs will be where your focus lies.  

 

 
 
First you decide which ROR curves and LCD’s you want to display, and the projection of them will be linear or 
Newton.  You will just have to play with those options and decide which you prefer. 
   
Secondly you decide on the filters tab how you want the curves to display.  If you want the curves to be the 
same during and after the roast your settings will be different than if you want additional post roast 
filtering/smoothing.   
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Filtering Raw Data 
 
Checking Drop Spikes will drop huge spikes that are within your set limits. This filter removes all readings that 
would result in a delta value that is either very high or very low compared to the previous deltas. This filter is 
able to catch spikes that happen in the standard range temperature values and can therefore not be caught by 
the min-max filter.  
 
Checking Limits will allow you to set temp limits on how high or low your curve can go.  This will keep your 
curves within reasonable ranges.  The setting limits the readings accepted by Artisan to the specified range. 
Selecting the standard range of expected temperatures during a roast often already eliminates most of the 
spikes, because meters experiencing electric noise often return very high or very low readings.  
 
 
IMPORTANT NOTE:  These two filters above are applied directly on the incoming data source before the data 
is recorded under Roast>Properties>Data tab. Therefore data eliminated by the min-max limit and the drop 
spikes filter is lost forever. This is in contrast to the other filters that in the remaining sections that work on the 
internal raw data and their effect is used to improve the visualization.  
 

Filtering During the Roast – All Curves 
 
Smooth Curves will impact the BT, ET and Delta curves.  This is the one you should adjust to your liking.  You 
have to balance between being able to read the data that is not too noisy and making meaningful adjustments 
to your roasting.  The only right answer is not what someone else sets, but how you use this to improve your 
own roasts and taste in the cup. Smooth Curves and Smooth Deltas also work on previously saved roasts.  If 
you have Optimal Smoothing checked you will have that algorithm apply over the Smooth Curves one. 
 
Checking Smooth Spikes will activate a further low-pass filter that eliminates tiny spikes that occur on some 
systems randomly due to some electronic noise. This filter is only applied offline if optimal smoothing is active. 
 

Filtering During the Roast – ROR 
 
Smooth Deltas will impact only the delta curves and is applied after the Smooth Curves setting ONLY FOR 
THE DELTA CURVES during the roast.  This allows for further refinement of your Delta curve.   
 
Delta Span affects how far back in time Artisan looks when calculating a delta curve. 

 Increasing this setting should smooth live-recording delta curves. 

 Increasing this setting will not affect the standard temperature curves (ET/BT/etc.), only deltas. 
 
 
The 3rd smoothing algorithm "Smooth2" has been removed. 
 

Filtering After the Roast 
 
Checking Optimal Smoothing turns on an alternative smoothing algorithm that does not produce and time 
shift (optimal in that respect) and can be applied only post roast.  It needs a complete roast as it looks at data 
forward as well as backward and forward data is not there during a roast.  If Optimal Smoothing is not checked, 
then online (during recording) and offline curve and RoR representation should be equal.  
 
 
IMPORTANT NOTE:  Except for the raw data filters, the filter settings can be changed after recording or even 
after restart of the app and reload of the file (which stores the raw internal data only) to generate variations of 
the BT,ET and Delta curve rendering. If you send an Artisan file (.alog) to another user she might get a different 
rendering on her screen depending on her filter settings.   
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Time axis configuration changes – Config>Axes 
There are now two primary Axes check marks, Auto and Lock. If Auto is checked, Artisan computes from 
CHARGE and DROP sensible axis limits to have the full profile shown on your screen.  If Lock is checked, the 
min/max limits will come from the profile that has been loaded.  If Lock is also not checked, what you might call 
Normal mode, a user can set the limit to his likes and those limits are preserved over anything in a profile that 
is saved or loaded. Lock is helpful if you plan to print out some profiles which should be scaled the same to 
make them easier to compare.  If you want to expand the x axis max during a roast by 3min check the Expand 
flag.  The RESET Min limit is new. This allows those that START quite early before CHARGE (like several 
minutes) to have Artisan set the x axis min limit on CHARGE (and also RESET) to the specified time. The 
RESET Max limit existed before and is set on each RESET.  If you hover your mouse over some of these, a 
tool tip pop up will appear. 
 

 
 
In this dialog you can change the style and appearance of your grid.  More importantly, focus on the lower part 
of this dialog and define the temp and delta ranges of your grid along with the steps to be shown.   
 

New Color Management and Themes  
New color themes and color management options are available under the Config menu.  Themes are new.  
They contain a color set that affects how the display appears.  Artisan comes with several built-in themes that 
are both attractive and useful as example starting point for user defined themes.  The built-in themes are 
available at Config>Themes>Artisan.  A user can save a theme by clicking Help>Save Theme. User saved 
themes can be loaded from Config>Themes>User.  Themes affect only the display on the screen.  They do not 
affect any of the other Artisan settings.  Note that themes are a subset of the Artisan settings saved and loaded 
from the Help menu.  
 
New in v1.3 is the ability to customize almost every color used in Artisan.  All these colors are saved in themes.  
If your foreground and background colors are too similar you will get a message to check them out.   
 
Also new are enhanced dialogs that display the chosen colors within the dialog. 
 

New Roaster Support 
Under Config>Machine, adds direct support for  

 Aillio Bullet R1 including profile imports 

 BC Roasters 

 Bühler Roastmaster 

 Coffed SR5/SR25 

 Coffee-Tech FZ-94 
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 Coffeetool R500/3/5/15 

 Giesen W1A/W6A/W15A 

 IMF RM5/RM15 

 K+M UG15/UG22 

 Loring S7/15/35/70 

 Phoenix ORO 

 Proaster 

 San Franciscan SF1-75 

 Sedona Elite 

 Toper TKM-SX 

 US Roaster Corp 

 
Other new features – some of these are BIG 
-- adds configurable alarm popup timeout at the bottom of the dialog.  With this the pop up appears and the 
goes poof off the screen after X seconds.   
- adds support for custom event values larger than 100 up to 999.  This will allow more precision in both 
controls as well as annotations on your graphs.  
- adds extraction yield calculator by Rui Paulo under Tools>Calculator 
- adds FC duration to characteristics 
- adds reload of last load profiles on app start 
- adds sliders with min/max limits adjusting to the actual temperature unit; slider style is redesigned 
- sliders and buttons remember their visibility per state (OFF/ON/START) 
- adds crash reporter 
 
 

Improvements to existing features 
- allows for 0.5s sampling rate  
- improves location of the stats summary calculations.  When Statistics>Summary is checked a display of 
selected statistics will be displayed on the right side of the graph.  When Config>Axes>Auto is also checked the 
axes will be adjusted so the summary statistics will not be on top of the graph curves.  The calculation for the 
axes adjustment is enhanced 
- various ranking report graph improvements 
- statistic summary layout improvements 
- enhances "Show on BT" to include all special events.  Many people will like this enhancement to show various 
adjustments during the roast.   
- allows alarm button action to trigger several buttons at once via a list. The following string is now valid: "1,2,3 
# docu" 
- allows one decimal in alarm value limits 
- redesigned slider styles 
- changes some defaults (DeltaET lcd hidden, render delta curves thinner than temperature curves) 
- keyboard mode jumps to the first non-flat button automatically -There is a "keyboard mode"  in Artisan, 
activated by pressing the Enter/Return key which allows you to select and activate an event button without 
using the mouse, but using the cursor keys and the Space key instead. On activating this mode, it was 
previously not ensured that the next EVENT not yet activated button was selected. This is now corrected. 
- deactivates mouse-over scroll wheel events on combo-boxes inside scrolling areas - on using a scroll mouse 
in a long alarm list, the scroll wheel would change values of combo boxes the mouse is just over instead of 
scrolling the whole list. The scroll wheel action for combo-boxes is deactivated in tables to avoid this situation. 
 

Technical developments for specific roasters/devices 
-adds MODBUS BCD decoding 

-adds support for the Siemens S7 protocol 

-Hottop default setup adds DROP action to put fan to 100% and heater to 0% and open the door and event 

quantifier definition 
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Fixes 
- fixes a bug that made the background RoR curves disappear on START 
- fixes a crasher on clicking the SV slider 
- fixes designer reset issue 
- fixes p-i-d button action that never triggered 
- fixes coarse quantifiers 
- fixes an issue where closing a confirmation dialog via its close box could lead to losing the recorded profile 
instead of canceling the activity  
- ensures that the persisted graph dpi is applied on startup and loading setting. 


